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1. Introduction

In travel agency brochures, on postcards and even on professional photos blue sky is often too 
dark and too blue. ‘Too blue’ means: plain blue instead of cyan-ish blue.  
One may suspect that this shift towards dark blue is already introduced by film material or by a 
digital camera itself.
Figure 1.1 shows a digital photo of a blue sky with clouds in July at noon in Emden (northern 
Germany). Aperture and exposure were adjusted until the brightest parts of the clouds were just 
not overexposed.
The original RAW photo was saved as RGB image in AdobeRGB(98) and further processed by 
Photoshop CS2. After gamut tests the images were finally converted to sRGB. 
Figure 1.2 is the result of a very little tonal correction by levels: the brightest parts were shifted 
accurately to level 255. Now it’s possible to measure the CIELab lightness L* or L in Photoshop’s 
Info Palette. CIELab, or Lab in Photoshop is explained in chapter 2. Top left we have L=31 and 
top right (in the sky) L=60. The left part is obviously too dark.
The trees are underexposed, consisting almost only of shadow. Photoshop’s tool Shadow / 
Highlight can be used to make the trees brighter without creating too much posterization. Simul-
taneously the sky becomes brighter. 
Figure 1.3 shows the pleasing result.  L reaches from 49 to 68 and the chromaticity values are 
typically a=-2...-7 and b=-39 to -29.

In chapter 5 the CIELab coordinates will be explained. Chapter 2 and 3 show, how the color of 
the sky can be modified without an accurate selection. These methods are based on Dan Mar-
gulis’ book about Photoshop Lab [2].

Thanks to Roger Breton, who had tried to measure sky blue directly by a colorimeter. It turned 
out to be rather difficult, because one needs not only a blue sky area but also the brightest part 
of the clouds as a reference for diffuse white with L=100.

Thanks to Norbert Kustos for providing many photos, here those in chapter 2, 3 and 4. The other 
photos were taken by the author. All photos were downsampled for this document to 1000 pixel 
width and resolution 144 ppi (pixels per inch).   

For a pixel synchronized and color corrected appearance in Acrobat please use these settings:

	 Edit > Preferences > Page Display
	 Custom Resolution 72 ppi

	 Edit > Preferences > Color Management
	 RGB	 	sRGB
	 CMYK	 	ISO Coated 	 here not relevant
	 Grayscale	 Dot Gain 20%	 here not relevant

	 Zoom	 	200%	 in this document

All images are shown pixel synchronized for zoom 200%, because of image resolution 144 ppi 
and graphics card resolution 72 ppi.

These settings are valid for Acrobat Professional 7. Eventually, not all features are available in 
the free Acrobat ‘Reader’.  
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Figure 1.1

Figure 1.2

Sky-01-01.tif
Original
July 14 / 2008 11:30
Nikon D100 / Raw
1/250
F16
sRGB

Sky-01-02.tif
Level adjustment
sRGB
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Sky-01-03.tif
Shadow / Highlight
S: 80% / 50% / 30px
sRGB
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Figure 1.3

Left to right
L	 =	 49	 ...	 68
a	 =	 -2	 ...	 -7
b	 =	 -39	 ...	-29
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2. Examples A / Lighter Sky

The sky in Figure 2.1 is obviously too dark: L=38. We are trying now to make the sky brighter 
without affecting the other parts and mainly without an accurate selection. 

Indicate color numbers by the Info Palette:
Window > Info > Click triangle top right > Palette Options > First Color Readout RGB > Second 
Color Readout Lab.
For several tools like Move Tool (top right in the Tool Palette), Path Selection (arrow) or Eyedrop-
per the color values at any mouse position are indicated in the Info Palette.

Choose the Lab color space: Image > Mode > Lab Color

By Polygonal Lasso Tool we make a very coarse selection which contains the whole sky and 
a part of the adjacent regions, the roofs. The reference points are chosen at the right side and 
at the top part outside the image. If the end point is near to the start point then a small circle 
indicates that the contour can be closed.
Then we map the outside contour parts to the image border by a trick: 
Select > Inverse > Inverse
The selection is then visible by ‘marching ants’. Changes concern only the selected part.  

Then we create an adjustment layer for curves:
Layer > New Adjustment Layer > Curves > Confirm default name > Normal

The new layer is indicated in the Layer Palette: Window > Layers

We get immediately the Curves diagram Figure 2.2. There are three options for the channels L, 
a, or b. We choose L and make the whole selection brighter by moving the curve end point top 
right to the left until the value for sky blue, as measured by the eyedropper, is near to L=60.
The result is shown in Figure 2.3. The edges of the roofs are now far too bright, of course. 

The top layer contains the new bright selection. The bottom layer is the old image (background 
layer). An overlay of both layers will be created by conditional blending:
Layer > Layer Style > Blending Options > Normal (default)
Figure 2.4 bottom:
Blend If > Channel b > 
Move the upper handles into the blue region until only the sky is copied
Move the lower handles into the blue region for an eventual improvement 
There are originally two handles for each slider. For soft transitions each handle can be split:
Alt + Click by Left Mouse + Move

‘Blend If’ means:
Copy the top layer only if its pixel color (b) is in the indicated range.
Copy the top layer only if the bottom layer pixel color (b) is in the indicated range.
In this example we could leave the lower handles at their end positions left and right.

Figure 2.5 shows the result. It can be saved as *.psd or *.tif with layers for further corrections.
We get rid of the layers by: Layer > Flatten Image
 
Finally convert to RGB and save as *.tif
Image > Mode > RGB Color
Save As > New name 
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2. Examples A / Lighter Sky

Figure 2.1

Figure 2.3Figure 2.2
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Figure 2.4

Figure 2.5
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3. Examples B / Lighter Part of Sky

The workflow is rather similar to Example 1, therefore the description is mostly copied..

The sky in Figure 3.1 is too dark in a small region: L=48. We are trying now to make the sky 
brighter without affecting the other parts and mainly without an accurate selection. 

Choose the Lab color space: Image > Mode > Lab Color

By Polygonal Lasso Tool we make a very coarse selection which contains the whole sky and 
a part of the adjacent regions, the hill.  The selection is accurate at the horizon.The reference 
points are chosen at the right side and at the top part outside the image. If the end point is near 
to the start point then a small circle indicates that the contour can be closed.
Then we map the outside contour parts to the image border by a trick: 
Select > Inverse > Inverse
The whole selection is then visible by ‘running ants’. Changes concern only the selected part.  

Then we create an adjustment layer for curves:
Layer > New Adjustment Layer > Curves > Confirm default name > Normal

We get immediately the Curves diagram Figure 3.2. There are three options for the channels L, 
a, or b. We choose L. Then we measure the value L for the dark part by eyedropper and distort 
the L-curve until the average lightness is L=60.
The result is shown in Figure 3.3. The edges of the hills are now too bright, of course. 

The top layer contains the new bright selection. The bottom layer is the old image (background 
layer). An overlay of both layers will be created by conditional blending:
Layer > Layer Style > Blending Options > Normal (default)
Figure 3.4 bottom:
Blend If > Channel b > 
Move the upper handles into the blue region until only the sky is copied
Move the lower handles into the blue region for an eventual improvement 
There are originally two handles for each slider. For soft transitions each handle can be split:
Alt + Click by Left Mouse + Move

‘Blend If’ means:
Copy the top layer only if its pixel color (b) is in the indicated range.
Copy the top layer only if the bottom layer pixel color (b) is in the indicated range.
In this example we could leave the lower handles at their end positions left and right.

Figure 3.5 shows the result. It can be saved as *.psd or *.tif with layers for further corrections.
We get rid of the layers by: Layer > Flatten Image
 
Finally convert to RGB and save as *.tif
Image > Mode > RGB Color
Save As > New name 
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3. Examples B / Lighter Part of Sky

Figure 3.1

Figure 3.3Figure 3.2
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3. Examples B / Lighter Part of Sky

Figure 3.4

Figure 3.5
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4. Examples C / Uncorrected images

This chapter shows a couple of uncorrected images, as delivered by the photographer Norbert 
Kustos. Only in Figure 4.4 a forgotten level correction was applied, shifting the brightest parts 
to white. 
These sky blues are considered as agreeable by the author of this doc, with the exception of 
Figure 4.3 which is perhaps too blue. 

Typical values for the skies:

Figure 4.1	 L=62...76	 a=-3...-6	 b=-10..-25

Figure 4.2	 L=59...67	 a=-3...-6, 	 b=-12...-26

Figure 4.3	 L=58...67	 a=-5...-8	 b=-43...-46

Figure 4.4	 L=61...80	 a=-9...-14	 b=-19...-32

For a comparison:

Title image	 L=59...67	 a=-4...-10	 b=-38..-45

Lab-values can be measured by loading the respective page in Photoshop. 
Mode sRGB, Resolution 72 ppi or 144 ppi. 

Thanks to Mike Russell [3] for his post:

Here are some Lab numbers collected by Jim Hamilton.  These values are
provided to curvemeister customers as a reference for a blue sky.  

The values are from photographs, taken at different times of year, in
Scotland.

The values of the first one are extremely close to your suggested value.
Cyan-blue is generally acceptable, whereas Magenta-blue looks unnatural.
The sky should also decrease in saturation toward the horizon.

Glencoe Sky	 Lab(68,-2,-45)  	 pin hue and saturation
Inverness Sky	 Lab(81,-11,-29) 	pin hue and saturation
Brodie Sky	 Lab(75,-7,-38)  	 pin hue and saturation
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4. Examples C / Uncorrected images

Figure 4.1

Figure 4.2
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4. Examples C / Uncorrected images

Figure 4.3

Figure 4.4
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5. CIELab

The CIELab color space is based on CIE(1931) colorimetry [1]. In Photoshop it’s called simply 
Lab, and the CIELab coordinates L*, a* and b* are called L, a and b.
Lab is a very powerful color space for editing, as described by Dan Margulis [2].
One doesn’t need to know the mathematical details [1].

The sRGB cone (Standard RGB) is mapped to a strange object in Lab, here shown for six diffe-
rent views for the same object.  Black is at L=0, a=0, b=0. White is at L=100, a=0, b=0. 
Any L=0 ...100 with a=0, b=0 is neutral (gray). The axis (a) points from cyan-ish green to red-ish 
magenta, or (simplified) from green to red. The axis (b) points (simplified) from blue to yellow. 
See also next page. Numbers for (a) and (b) are in Photoshop in the range -128 to +127.
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Figure 5.1
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5. CIELab

This diagram shows a horizontal slice of the Lab volume for sRGB at L=50. The gray area shows 
the range -100 to +100 for (a) and (b). The colored area shows the maximal projected area of 
the whole volume. The black contour contains the valid colors for L=50.
We can see that ‘(a) from green to red’ and ‘(b) from blue to yellow’ are simplified descriptions.
Furtheron, darker yellows don’t exist - these colors are browns.
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5. CIELab

Curves (more accurate: gradation curves) define the relation between the old input (horizontal) 
and the new output (vertical). They are initialized by a straight line bottom left to top right.
In RGB mode we have either RGB (luminance) or single channels R, G, B. In Lab we have the 
channels L, a and b.
The origin for the L-curve is bottom left for black. The origin for the (a) and (b) curves is in the 
middle: a=b=0 for grays. The axes are going from green to red and from blue to yellow. 
In Margulis’ book the axes are swapped, as traditionally done for CMYK. This is indicated by the 
black-white gradient: then white is left, black is right.

A few examples for modified curves (white lines): 

Figure 5.3
Absolutely increasing lightness.

green                   red

blue                 yellow

Figure 5.4 
Less vivid green. The same red.

Figure 5.5
More vivid yellow. The same blue.

Assign numerical values to any mouse point, here 0,0

black                white
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